Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/29/d327710490/htdocs/wp_fixed_circular_nav/wp-content/plugins/dw-question-answer/inc/Status.php on line 247
class="post-489 dwqa-question type-dwqa-question status-publish hentry dwqa-question_category-technical dwqa-question_tag-icons">

Custom Icons not reflecting

Question & AnswersCategory: TechnicalCustom Icons not reflecting
Carel Loubser asked 6 years ago

I added custom icons in png format at different sizes, but the icons are not displaying on my mobile or on my desktop. http://www.wilderness-safaris.mobi
Thank you

1 Answers
quique Staff answered 6 years ago

Hi Carel,
 
The theme you are using for your website is forcing all the images in the page to have the property “display: block” (which is quite unusual).
 
The quickest solution is to add this lines to your stylesheet (via Admin panel: Appearance -> Editor -> edit the style.css):
.cn-modern .cn-wrapper li a span img {

    display: inline !important;
    padding-top: 20px;
}
 
The display property will prevent the general rule in your style to be applied to the menu.
The padding added is to fix a little bit the overall result given the settings of your current theme. It is the pad between text and the icons themselves. Feel free to tweak it and play with it until you are happy with the results (try 10px, or try 30 px, etc).
 
Please, if you have any doubt about how to apply this changes here we are 🙂 And please tell us of you manage to get the menu working as you want.
 
Best wishes